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Introduction
I originally wrote this little program to print envelopes in my office.  Handwritten envelopes were very 
unprofessional looking. To load Microsoft Word or OpenOffice and setup the program to print just one 
envelope took 3-8 minutes.  

Therefore, I set out to write a simple program that would be quick and easy to use to print single 
envelopes.  Envelope Printer start as very basic, really quick, and very easy to the point that I could go 
from program start to printed envelope in about 15 seconds.  After some internal debates, mostly about 
potential support issues, I finally released the first version back in March of 2010.

Just days after I released the program to several software download sites my program was written up by 
Wanda Sloan with the Bangkok Post.  My program was downloaded over 10,000 times within the first 
couple of days after Mrs. Sloan's article was posted on the Bangkok Post.  The number of compliments 
and request for features resulted in my dividing the program up between a U.S. Version and an 
International/Non-US Version to accommodate International needs.

Since 2010, the program has gone through several updates (all of which have pretty much come from 
end user suggestions) but the program remains just as fast as the original version.   I can still open the 
program, enter an address, and print an envelope in 12-15 seconds.  If the address is one I know is in 
the address book, I can get the envelope printed in 8-10 seconds.

Through version 2.00 the program has been downloaded over 30,000 times.  I hope all of these users 
are actually using the program and have found it to be as beneficial as I have.

Version 2.50 is a major upgrade adding a ton of features mostly aimed at the new Pro Version:
• Standard Version still FREE for Personal and Commercial use
• Reasonably priced Pro Version, only $8.99
• Can install Pro Version to 3 computers (Home, Work, Laptop)
• Authentication of Software (Pro Version) 
• Multiple Address Books (Pro Version) 

• Can save address books in any directory that you have write access (Pro Version)
• Can save address books to Dropbox, GoogleDrives, Box, and other cloud storage 

services to have access from anywhere (Pro Version)
• Set To Font (Pro Version) 
• Set From Font (Pro Version) 
• Print Preview (Pro Version) 
• Print Multiple Copies (Pro Version)
• Menus
• Toolbar Quicklinks
• Web-based Update Checker
• Double-Click Select in search window



Overview

1 Return (From / Sender) Address fields (Automatically Saves)

2 Set the Font Characteristics for the Return (From / Sender) Address fields

3 Addressee (To) Address fields (Automatically Saved on Print only)

4 Vertical and Horizontal Alignment Print Adjustments

5 Search for Addressee (To) Addresses

6 Clear the Addressee (To) Address fields

7 Save the Addressee (To) Address fields (NO PRINT)

8 Delete the displayed Address (Clears the fields AND removes record from addressbook)

9 Set the Font Characteristics for the Addressee (To) Address fields

10 Shows the “Help” and “About” screen and credits

11 Printer Selection Drop down

12 Print the Displayed Addressee Envelope

13 Menu Bar

14 Tool Bar

15 Title Bar  (Envelope Printer {Standard/Pro} ver_no. - {current addressbook name}

16 Path to current address book being used



Return (From) Address

Return Address Fields

This is the address that appears in the upper left hand corner of the envelope.  Typically 
this is your address or your businesses address.  Also known as or called the “From” 
address.

There are only 3 lines for the return address, used to provide the following information:

Sender's Name or Company Name
Address Line (with Department or Suite information)
City, State Zip code

Actual Return Address Printed Font is selected using the “Set Sender Font” button 
located directly below this section.  The default font is “Arial”, “12 pt”, “Regular”

There is no automatic zip code lookup function associated with this section as you 
should know what your zip code is and you will not be changing this information.

These fields are automatically saved whenever there is a change to any field.

Does not have to be Return address can actually be any three lines of text.

However, if you do not put your Return Address information here and there is a problem 
with your mail the post office will not be able to return this piece of mail and it will end 
up in the “Dead Letter” facility of the postal service.

Pro Version: Each address book is associated with it's own return address.  Changing 
the return address only changes it for the currently selected Address Book.



Addressee (To) Address

Consists of up to 4 lines of text:

Line 1:  usually the person or business name that you are sending TO

Line 2:  can be used for an ATTN: line or as the first line of the address
(See below for examples)

Line 3:  can be used for the address line if an ATTN: line was used on line 2, or it 
can be an additional address line (i.e. suite, apt, etc) if needed.

Line 4:  is the City, State and Zip code.

When you enter the zip code the system will look-up the name of the City and 
State from a 40,000+ zip code database (please see our website for notes  
concerning this zipcode database).  These fields will be automatically filled in if 
they are found.  The database is primary zip codes + PO Box Only zip codes. 
Military APO and FPO zip codes are not included.  Look-up based on first 5 
digits of zipcode only.  Does not verify Zip+4 accuracy. 

Tab order is Line 1, Line 2, Line 3, Zipcode, City, State
EXAMPLES

Normal w/ Suite Line

w/ ATTN Line



Print Preview

You can either select 

File->Print Preview 

as shown to the left or you can 

simply click on the Print

Preview button in the tool bar

as show below.  Either way

will give you the same result.

The below Print Preview

example shows the Sender

(From) address in Times New

Roman, Italic, 12 pt font while

the Addressee (To) address is in

Arial, Bold, 16pt Font.



Changing where Addresses Print on Envelopes

Measurement units for printing on envelopes is set to Points.  I tried using millimeter (mm), but the 
results were very inconsistent between printers.  It is strange that a millimeter (mm) is different with 
different printers, but that is what I ended up observing.  Points tended to give the most consistent 
location for printing.  Using the Vertical and Horizontal Location boxes you can enter “offset” from 
default locations.

Sender/Return/From address defaults are Vertically 0 points and Horizontally 0 points
The Addressee/To address default is Vertically 2508 points and Horizontally 900 points

The above is NOT to Scale

There are a couple of things that you need to know at this point now.

The Sender/Return/From address offsets are simple addition equations:
Vertical Printing Location is calculated from 0+(Vertical Offset #) 
Horizontal Printing Location is calculated from 0+(Horizontal Offset #)

The Addressee/To address offsets are a bit more complicated.  
Vertical Printing Location is calculated as follows (900 + (Vertical Offset * 9))
Horizontal Printing Location is calculated as follows (2508 + (Horizontal Offset * 12)) 

Point to remember:
Positive numbers in the vertical offsets move addresses down, negative moves the address up.
Positive numbers in the horizontal offsets move the addresses right, negative numbers left.

Return Address
Street
City, State, Zip

Horizontal Placement

V
e
r
t
i
c
a
l 

0
0

Addressee Name
Address Line 1
City, State Zipcode

2508
900

2

1



Search Function

Enter a partial name in the TO section and press the “...” button.  This will pull up a search window 
with all names matching the partial name you entered.  If you leave the name in the TO section blank 
and click the “...” button you will get a search window listing all names and addresses in your address 
book. (example of the search window is below).

In the search window you can either Double-Click on any name to automatically return that name to 
the main screen filling the TO fields as appropriate or you can highlight a name and click Select.

The search feature is Case Sensitive  .    If you enter the letter “K” in the “TO” Address name field and 
press the “...” button you will get a listing of all names that start with “K” but not any names that start 
with “k” since the search is Case Sensitive. 



Clear, Save and Delete

Clear button clears the information entered in the TO address fields.  If you entered an address and 
decide not to print nor save it, or you searched for an address and do not need to print an envelope after 
all, you can click Clear to remove the information and start a NEW blank address record. 

NOTE: If you search for an address and select an address that is returned to the Main Screen filling in 
the TO address information, if you make any changes to that address and click “Save” or “Print” then 
that address record will be overwritten with the new information, effectively deleting the old 
information.

I do work in a doctor's office that requires me to send appeal letters to insurance carriers that have 
denied claims for services.  Many insurance companies have multiple addresses in which these letters 
must be sent depending on the employer group, benefit plan, etc.   Therefore, I have multiple 
“Insurance Company Names” that are the same but different address information.  In order to 
accomplish this, I must set up each different address individually in a blank record.  I do not search for 
the insurance carrier and change the address information as this would just overwrite the address 
information that I have in the address book.  

Instead, I enter the name of the insurance carrier, highlight  the name and then either press CTRL+C 
(Copy) or select Edit->Copy from the menu.  I then enter the address information for the first appeals 
address and click “Print” or “Save”.  The TO Address fields are reset to blanks, I make sure the cursor 
is in the Name field and press CTRL+V (Paste) or select Edit->Paste to paste the Insurance Company 
Name into the field.  I then enter the address information for the next group/benefit plan and click 
“Print” or “Save”.  I keep repeating this process for all of the appeals addresses.

Save button saves the TO address information that you have entered without printing an envelope.

Delete button is used after you have used the “...” (Search function) to select an address in the address 
book that you would like to delete.  The process to delete records is as follows:  1) Enter a partial name 
in the TO address Name field, 2) Click the search button “...”, 3) Select the correct name and address 
combination by either Double-Clicking on it or by highlighting and clicking “Select”, 4) when the 
name and address are returned to the main screen TO fields you then click “Delete” to delete the 
record.



About

Clicking the About button just pops up a quick about window with information About this program.



Printer Selection
Many users had problems with the default Windows print selector.  I personally just don't  like the 
excessive amount of Windows space required to make a simple selection. 

Thus, the NEW, SIMPLER PRINT SELECTOR.

Using the drop down selector, highlight and click on the name of the printer you want to use.

That's it !  Nothing else to do!  System will remember which printer you last selected.



Printing

When you press the PRINT Button the entered information will be printed and the TO address 
information will be automatically saved. 

The TO address fields will be cleared, ready for the next address to be entered.  If you searched for an 
address and made any changes when you press print the changes will overwrite the information that 
was in the original address record.

Pro Version:
When you click on the print button you will be given the opportunity to print multiple copies of the 
same envelope.  

This feature is great if you want to pre-print envelopes for later use.  For example, you may get a 
monthly bill from a company that does not include return envelopes.  You could print six months of 
return envelopes for this bill and place it with all of your other bill paying materials.  Or maybe you are 
going to go on a trip and want to send letters back home to friends.  You could pre-print the envelopes 
to pack and take with you.

The default is one (1) and you just click “OK” or hit return.  If you do not want to print, you can enter 
zero (0) and that will cancel the printing.  If you enter a negative number nothing will print.  Next 
release I will change it so that if a negative number is entered the program will take the ABS(#) 
(absolute value) and print that number of copies.



Miscellaneous Information
A standard menu and toolbar have be added to the program.  Not all functions are accessed through 
these.  Search, Clear, Delete are only accessed through the buttons on the main screen.  Setting the 
vertically and horizontal offsets and Printer Selection are only accessed from the main screen.

Above the standard menu is the Title bar.  The title bar simple shows the name of the program, whether 
you have the Standard or Pro version, the current version number you are running and the currently 
accessed address book name.

At the bottom of the main screen is a complete file path of the currently accessed address book.  The 
file path includes the file name.  This information is useful to help 

In the File menu you can Print and Print Preview.  These functions are also available by clicking on the 
toolbar icons 

In the Edit menu you can Cut, Copy and Paste.  These functions are also available on the toolbar using 
the                     icons.



Pro Version Features
(not already covered)

If you have the standard version of Envelope Printer v2.50+ you can upgrade to our PRO version by 
clicking on Help->Purchase PRO.  This will close the program and start Internet Explorer.  IE should 
be directed to our web storefront where you can purchase the PRO version.  Once you purchase the Pro 
version you will get a “Thank you for your purchase” web-page.  This web-page has an activation code 
where every other character is replaced with “x” and can not be used.  

You will receive an email from our web store vendor that is a receipt and contains the FULL activation 
code.  Once you receive the activation code you start Envelope Printer and click on Help->Enter 
Activation Code.  The process is pretty straight forward.  On the first screen enter the activation code 
and click NEXT.  On the next screen enter a password to secure your activation code to you.  Future 
activations/reactivation require this password.  Enter an email address for password recovery should 
you forget the password.  Click Next.  The system will connect to the internet-based authentication 
servers and license your software.  

The PRO version license allows for installation on up to 3 computers (i.e. Home, Work, Laptop) for 
your individual use.  The 3 installations are meant for your use for both personal and commercial use. 
Each installation has can either have it's own address book, which can be different from the others, or 
you can have an address book on Dropbox, GoogleDrive, or other cloud drive and have all computers 
accessing the same address book.

While I provide a fairly broad license, I ask that you use each purchased PRO version license in the 
manner that it is meant to be used, that is by you (and anyone who uses your computer, i.e. family) on 
each installed computer. 

Please do not install one of your licensed copies on your home computer for your use, one license on a 
friends computer for their use and one license on your secretary's computer for his/her use.  This is a 
violation of the license and while I can not track this abuse, bad karma will follow you for doing this. I 
have priced the Pro version license at a very reasonable rate and ask that you purchase appropriately.



Pro Version: Multiple Address Books
The Pro version of the program allows you to have multiple address books.  Each address book is 
associated with it's own Sender/Return/From address.  This allows you to have a personal address book 
with your home address in the Sender/Return/From address and a business address book with your 
office address in the Sender/Return/From address.

Another use of the multiple address books is in a family environment.  The wife has an address book 
with her name and home address in one book, the husband has his address book with his name and 
home address in another book, then there is a Christmas address book, where the return address is “The 
Jones Family” with the home address.

Address books can be saved anywhere on your computer system where you have “write” privileges. 
Basically if you can see a directory and save files to that directory, then you have “write” privileges to 
that directory.  Additionally, you can save the address book to a Dropbox, GoogleDrive or other cloud-
based storage service, provided the service creates a directory on your local drive that is sync'ed to the 
cloud service.  If you can access the directory from Windows Explorer you can probably save the 
address book to that service.

This feature is useful if you want to have one shared address book stored on the cloud-based storage 
service that can then be accessed by all of your computers where you have Envelope Printer installed.

Use the File->Load, File->New and File->Save or the three toolbar icons                       to create and 
access additional address books.



Pro Version: Changing Printed Fonts

When you click on the “Set Sender Font” or the “Set To Font” you will be presented with the 
standard Windows Font Selection panel.  You can select any font, Font Style and Size that you 
currently have installed on your system.  Envelope Print v2.51 only recognizes the “Regular”, 
“Bold”, “Italic” and “Bold and Italic” versions of the fonts.

Font changes are automatically saved when “OK” is pressed.  The font selection will remain for 
all future use of Envelope Printer.  No need to re-select your font choices each time you start the 
program.  If you click “Cancel” the fonts will remain unchanged.

Default fonts the first time you run the program are as follows:

Sender (From) Font: “Arial”, “Regular”, “12pt”
Addressee (To) Font: “Arial”, “Regular”, “16pt”



Hints, Tricks and Tips
Multiple Addresses

If you need to have multiple addresses with the same business name but different street 
addresses (i.e. a doctors office that mails claims to different claims processing centers) then you 
will need to manually enter ALL of the information and use the “Save” button for each location 
without using the search function.

Multiple addresses can be entered into the Addresses.adb file by simply entering the TO 
information and clicking the “Save” button.  The “Save” button will save the information and 
clear the TO fields for the next address to be entered.

Alternatively, you can manually create an Addresses.adb file using notepad.

The format is as follows

Address Name^Address Line 1^Optional Address Line 2^City^St^Zipcode^0,1
Address 2^Address Line 2 Line 1^Optional Address Line 2 Line 1^City^State^Zipcode^1^1
Address 3^Address Line 3 Line 1^Optional Address Line 3 Line 1^City^State^Zipcode^2^1
Address 4^Address Line 4 Line 1^Optional Address Line 4 Line 1^City^State^Zipcode^3^1

Example Addressess.adb file

I use the ^ character to break between fields.  A normal CR+LF at the end of each line to 
separate records.

The last two fields are record number and address type.  All addresses are type “1” at this time.

If you have a database that you want converted, please contact me at ep_support@yasdc.com 
and I will work with you on a conversion program to meet your needs.

Deleting Addresses
Follow the directions found earlier in this guide.

If you must delete addresses manually you can.  Open the Addresses.adb file using any text 
editor (i.e. Notepad) do not use Word or editors that add extraneous information.  The address 
file that you want to edit can be found using the full path that is listed at the bottom of the Main 
Screen.  Locate the line with the address you wish to delete. Highlight that line and delete it. 
Change the record number at the end of all addresses that follow after.  (This is why it is better 
to use the procedure found earlier in this guide). File->Save. Exit.

mailto:ep_support@yasdc.com


Inserting Envelopes into the Printer

Please refer to your printer manual for using your printer for printing envelopes.

On several HP Laser and Deskjet printers the envelope is inserted using this method:
1) move the Manual Paper Feed Guides to envelope width
2) insert the envelope face up (flap should be down) with the flap on the left hand side
3) push envelope into the manual feed area until resistance is felt, STOP
4) do not force or push excessively to feed envelope into printer

From the HP Website

Step 4: Insert your envelope into your printer’s document feeder the same way you insert paper. 
Most printers will indicate which way to insert your envelope with an illustration on the 
document feeder (vertically vs. horizontally, face up vs. face down).

Before printing, follow these additional tips to avoid paper jams and other printing mishaps:

• Check the packaging to be sure your envelopes are compatible with your printer. 
• Avoid printing on envelopes that are loosely constructed, as they can get caught in your 

printer or document feeder. 
• Do not try to print on envelopes that have clasps, strings, or buttons. Hand address or use 

labels instead. 
• If you’re printing a stack of envelopes, stack them loosely to avoid a jam.

Most printers have built-in support for popular envelope sizes. Some even have special trays for 
feeding envelopes. If your printer has an envelope tray, be sure to enable the "load from 
envelope tray" option in the print dialog box before printing. 

http://h20331.www2.hp.com/hho/cache/344420-0-0-225-121.html

Envelope Print 1.13 always prints from wherever there is available paper.   So be sure to use the 
manual feed or remove your normal paper from the tray before printing.

HINT:
You can cut out several pieces of paper to match the size of your envelope.  On one side draw a 
flap on each piece.  Then feed the paper in different manners so that the printer prints on the 
side without the flap and with the addresses oriented in the manner you want for stamping the 
envelope.

Note for Windows Vista and Windows 7 Users (and now Windows 8)

If you have the User Account Control (UAC) turned on your computer then your 
Addressess.adb file may be saved to a UAC “Safe” location.  Uninstalling the program and 
reinstalling it will not erase the Addressess.adb file from this location and must be manually 
deleted.  Under this situation re-installation will continue to “Search” this old file and will 
confuzzle you as to why.  

You may need to run the program as “Windows XP” compatible and “As Administrator”.  See 
our website NEWS section for instructions about this.

http://h20331.www2.hp.com/hho/cache/344420-0-0-225-121.html


ANTI-VIRUS, ANTI-MALWARE PROBLEMS
I use PUREBASIC development environment and compiler for Envelope Printer.  AVG Anti-Virus and 
MalwareBytes Anti-Malware both report the program as having a trojan in the exe file.  These are 
FALSE positives.  The reason they come up is because of the program accessing the Windows API 
directly for several functions in order to get the best possible results/speed.

I have posted the MD5 checksums on my website (http://www.yasdc.com) under the NEWS section. 
You can download the installer and check the MD5 before installing.  Then once installed you can 
check the update25.exe file and finally the ep.exe file.

Update25.exe is a small program that needs to be run after you install version 2.50.  This fixes two 
minor problems related to v2.50.  After running the update25.exe your version should read v2.51.

Windows Vista, Windows XP, Windows 7 and Windows 8 all utilize Microsoft Authenticode to run 
trusted programs.  An untrusted program will show a window that asks if you want to continue. (see  
below)

I do not have an Authenticode digital signature at this time because I do not believe in paying extortion 
money to companies with multi-billion dollar revenues to allow my program to run on my computer.  

Now, I understand that by making my software available to the public that you the end user needs some 
assurances that my program is not spyware, malware, or contains a virus.  To accomplish this I have 
published the MD5 checksums of my files so that you can be assured that you are getting my original 
files.  I understand that you must “trust me” as being a benevolent individual and not some hacker 
sociopath. 

If you choose to run Envelope Printer, then I thank you.  If you purchase the Pro Version, I really, 
really, appreciate you.  If there are enough people who want me to have the Authenticode digital 
signature, I will do so.  I will use Pro Version sales as the guage to my need to get an Authenticode 
digital signature.  If I get enough Pro version sales to cover the $200+ per year or so fees to acquire and 
maintain the Authenticode digital signature I will get one. 

http://www.yasdc.com/


SUPPORT
Envelope Printer was written by me, Kevin Perryman of Kerrville, Texas, USA.  I am the sole support 
for this program.  I wrote Envelope Printer to meet a need that I had.  I am sharing Envelope Printer 
with the general public, figuring that if I had the need, so do others.

If you email ep_support@yasdc.com I will respond just as soon as I get the email.  If I have to do 
research I will respond that I am looking into the problem.  Be assured that as soon as I press send, I 
am opening up my development environment and looking into your concern.  In fact, within just a 
couple of minutes, I usually will send out a second email either asking for more information, or for you 
to try something so I can narrow down the possible causes, or providing a solution.   

While I do not live by my email, I do check it multiple times per day Monday – Friday and several 
times on the weekend.  I will respond when I get the email, not the next business day.  I post news 
items concerning problems found on my website (www.yasdc.com) under the NEWS section, so check 
that out to see if the problem has already been addressed.

I know from website logs that the program has now been downloaded over 30,000 times.  I also know 
that many of the people who download the program, use it one time, have a problem and quit using it. 
If instead you read through this user guide and/or contact me with any remaining problems, I am sure 
we can get the program working correctly for you.  

I want everyone who downloads this program to use it to make their life easier.   If there are problems, 
I need to know so that I can fix them.  I will do whatever it takes to make this program one of the best 
out there.  Other than the basic envelope printing functions from version 0.10 every new feature that 
has been added over the past three years came from end users who took the time to contacted me.

I have a saying, “I am willing to work with anyone, provided they are willing to work with and 
communicate with me”.  If you do not communicate with me, I can not work with you, simply because 
I do not know that there is a problem.  I ask that you don't abuse this willingness on my part, but at the 
same time ask that you do utilize it.

Again, thank you for taking the time to look through this users guide and for using Envelope Printer. 
Please let me know if you have any comments, concerns, requests, problems, or needs.

Kevin Perryman
Yet Another Software Development Company (YASDC)

http://www.yasdc.com/
mailto:ep_support@yasdc.com

